GA Doesn't Support

Description

In GA, if you don't have the necessary code change implemented, GA will not be able to show the new Demographics and Interest reports. Instead, the following error message is displayed.

Your Demographics and Interest Reports have been enabled, but your Analytics tracking code does not include the necessary support to show them. Learn more about the simple, one-line, one-time change to your tracking code to add this support.

In the rendered GA code, this line:

ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';

Should be updated to this:

ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';

Reference: https://support.google.com/analytics/answer/2444872?hl=en&utm_id=ad

QA Test Plan

None

Status

Assignee

Robert Cui

Reporter

Will Strohl

Story Size

None

Severity

None

Triage

Triaged

Fixed in Build

None

Dev Owner

None

Includes Code Fix

No

Documentation Required

No

Trouble Ticket

None

Requires More Info

None

QA Story Points

None

QA Owner

None

Injected

None

Automation Required

None

Code Review Owner

None

Story Points

1

Components

Sprint

None

Fix versions

Affects versions

Priority

High
Configure