SharpZipLib latest version

Description

SharpZipLib is used several placers throughout the Platform framework (as well as by some third-party extensions). The base version needs to be upgraded (for fixes and licensing reasons).
We are currently running 0.81.0.1407 (in 9.1.1) and we need to update the version to 0.86.0.518.

https://github.com/icsharpcode/SharpZipLib/releases

Note: We will also have to upgrade the license (text file) we ship as the licensing has changed to MIT since we last updated (which is a better license type).

QA Test Plan

None

Activity

Show:
George Alatrash
August 29, 2017, 6:33 PM

Added another PR for PB Extenstions and assigned to
PR: https://github.com/dnnsoftware/Dnn.AdminExperience.Extensions/pull/222

amarjit dhunna
August 29, 2017, 6:34 PM
Edited

Changes look good and merged in Platform #9.2.0.92-232

Amritpal manak
September 26, 2017, 10:00 PM

Verified in Platform 9.2 build 139-310 and its fixed , Please refer to the screenshot:

Bing Wu
September 26, 2017, 10:31 PM

Please cover installation, Upgrading, Install a module(zip) or Skin, Upload zip files in DAM.

Amritpal manak
September 26, 2017, 11:59 PM

installation, Upgrading, Install a module(zip) or Skin, Upload zip files in DAM.

Assignee

Amritpal manak

Reporter

Arno Pieterse

Story Size

S

Severity

Minor

Triage

Triaged

Fixed in Build

Dev Owner

George Alatrash

Includes Code Fix

No

Documentation Required

No

Trouble Ticket

None

Requires More Info

None

QA Story Points

None

QA Owner

None

Injected

None

Automation Required

None

Code Review Owner

None

Story Points

2

Components

Sprint

None

Fix versions

Priority

Medium
Configure