Do not fail upgrade wizard upgrade when a newer module is already installed

Description

In some scenarios, a site may have a newer version of a module installed, while the DNN / Evoq upgrade package might contain an older version. This will be true for Security Analyzer. If you have an older DNN / Evoq and applied the latest SA, and then later to a newer DNN / Evoq with older SA, the upgrade process fails half way.

It completely destroys the side.

We need to log a warning and not upgrade the module if it's older.

QA Test Plan

None

Status

Assignee

Vikas Sisodia

Reporter

Ash Prasad

Story Size

S

Severity

Major

Triage

Triaged

Fixed in Build

None

Dev Owner

None

Includes Code Fix

No

Documentation Required

None

Trouble Ticket

None

Requires More Info

None

QA Story Points

None

QA Owner

None

Injected

None

Automation Required

None

Code Review Owner

None

Story Points

2

Components

Sprint

None

Fix versions

Priority

Low
Configure